Thursday, April 24, 2008

Do not upgrade to Discoverer

October 2008 Important Update: Oracle released CP2 for on October 3, 2008

I urge you not to stay on the non-updated base install of You should apply CP2 or CP1 as soon as you can (link to patches)

I have recently been contacted by someone asking for help with Discoverer - I'm guessing most of you never even knew that it had been released. There was certainly no big splash about this anywhere that I have seen.

Anyway, it was released 0n 07-MAR-2008 as part of Application Server 10g patch set 3, which you can find on MetaLink as patch number 5983622. This is a major patch and can be applied on top of, or However, when it was first released it was very buggy which is why both Oracle and myself were recommendingyou should not apply it at that time.

Happily, you are safe installing so long as you apply at least CP1.

However, if you are using E-Business Suite, Oracle is still not recommending customers not to upgrade to Discoverer because:
  • is not yet certified with E-Business Suite 11i or 12. This work is currently in progress and the appropriate notes will be updated when the certification is complete.

Therefore, if you have already upgraded to you need to reverse that and get back to a stable version of 10.1.2. At that point, if you have not already done so, you need to upgrade to (patch number 4960210) and then apply the latest 10.1.2 cumulative patch. As of the date of this posting this is CP8 which was released during July and August 2008. You can find it on MetaLink as patch number 7306816 (if on Linux, Solaris or HP) or 7111816 if you are using Windows.

Optionally, especially if you want to interface Discoverer 10g with BI Publisher you will need to also apply the web services patch which for CP4 and above is 6622352.


Ramesh Mani said...


Thanks for the informations.

Ramesh Mani

Anonymous said...

Is this still your current recommendation? Oracle is pressing me to install now and I find a lot of conflicting information.

Michael said...

So what exactly are Oracle saying? In my opinion you will be ok going to now that there are cumulative patches for it. However, stay away from CP3 as it is buggy. Either install CP2 or wait for CP4. This link will help:

Best wishes